Xcode升级,插件不能正常使用

作者:佛前一粒沙    发布于:

Xcode升级,插件不能正常使用

昨天不小心升级了一下Xcode ,然后 今天使用的时候,发现插件使用不了了,比如我们常用的插件 VVDocumenter-Xcode(注释插件)

接下来我们教大家 如何让插件变得可用

1.打开终端。输入

defaults read /Applications/Xcode.app/Contents/Info DVTPlugInCompatibilityUUID

然后我们得到序列号(这里是得到你本机的序列号)

如图

然后我们复制这个序列号,备用。

2.打开finder,然后command+shift+G 组合键。然后弹出个框框。然后 我们输入xocde插件路径:

~/library/Application Support/Developer/Shared/Xcode/Plug-ins

如图

3. 点击前往,我们找到插件

如图

4 .接下来 我们以其中的一个插件为例(其他插件的操作一样)

1.我们选择插件,然后点击右键(显示包内容),如图:

2 .我们看到下面的界面:(如图)

3 .我们点击打开这个文件夹 ,接下来显示内容如图:

4 .然后我们打开info.plist 文件,如图:

然后 找到 如图所示的地方:

然后 增加一个Item 如图:

然后 把我们第一步复制的xcode 的序列号添加进去。。(Command+s 保存plist 文件)

5 .接下来 重启Xcode 以后会弹出一个框框, 重启Xcode时会提示“Load bundle”、 “Skip
Bundle”,这里必须选择“Load bundle”,不然插件无法使用。

总结:xcode升级以后,因为序列号不一样,所以我们要更改序列号。。。

format_list_numbered

(无)

  1. 1. Xcode升级,插件不能正常使用
vertical_align_top

Copyright © 2017 佛前一粒沙的博客

Powered by Hexo & Theme - Vateral